Model # R29WH

Internet #203826373

Juno Trac-Lites White Floating Electrical Feed
0661209031129

Juno

Trac-Lites White Floating Electrical Feed

$11.03 /each

Frequently Bought Together

Product Overview

The Juno Trac-Lites Floating Electrical Feed connects a track section to a standard junction box at any point along the track section length. White J-box cover and floating connector mount the track section directly beneath the box. The floating feed features an embossed polarity arrow that points to a polarity line on the track, assuring proper electrical connection and simplified installation.

Info & Guides

You will need Adobe® Acrobat® Reader to view PDF documents.  Download a free copy from the Adobe Web site.

Specifications

Dimensions

Details

Warranty / Certifications

More Products With These Features

Search

Customer Questions & Answers

Does it work with con tec track

Asked by: rvk
Hello, this component is only compatible with Juno Trac-Lites track systems. Thanks!
Answered by: junoJT
Date published: 2016-03-23

Does this come with a dead end connector cap

Does this come with a dead end connector cap
Asked by: joe
This item does not include a dead end connector cap.
Answered by: CommunityAnswer
Date published: 2016-12-10

how many are needed for a 4 track installation

I'm installing 4 sections of Juno 4 ft track. How many of these units do I need to complete the installation? Thanks.
Asked by: Librarian
Hello, each track circuit needs one feed so various joiners, elbows or tees can be used to connect the track and avoid more feeds. The feed is tied to the circuit breaker which will dictate the maximum amps that can be used. The track is rated for 20 amps. Those joiner item #s can be found at the following link and can be accessed through the search tool on Homedepot.com. http://www.junolightinggroup.com/attachments/images/content/SpecSheets/D2_1_0.pdf Thanks!
Answered by: junoJT
Date published: 2016-03-10

Does this work to connect 2 track sections or just feed?

Example: I have looked at the manual and can't figure out what I did wrong.
Asked by: Dave
  • y_2017, m_3, d_21, h_4CST
  • bvseo_bulk, prod_bvqa, vn_bulk_1.0.0
  • cp_1, bvpage1
  • co_hasquestionsanswers, tq_4
  • loc_, sid_203826373, prod, sort_[SortEntry(order=NUM_ANSWERS, direction=DESCENDING), SortEntry(order=SUBMISSION_TIME, direction=DESCENDING), SortEntry(order=LAST_APPROVED_ANSWER_SUBMISSION_TIME, direction=DESCENDING), SortEntry(order=LAST_APPROVED_ANSWER_SUBMISSION_TIME, direction=DESCENDING), SortEntry(order=BEST_ANSWER_FEEDBACK_COUNT, direction=DESCENDING), SortEntry(order=POSITIVE_ANSWER_FEEDBACK_COUNT, direction=DESCENDING), SortEntry(order=NUM_ANSWERS, direction=DESCENDING)]
  • clientName_homedepot
  • bvseo_sdk, java_sdk, bvseo-3.1.1
  • CLOUD, getContent, 32ms
  • QUESTIONS, PRODUCT

Customer Reviews

  • bvseo_sdk, java_sdk, bvseo-3.1.1
  • CLOUD, getContent, 42ms
  • REVIEWS, PRODUCT
  • bvseo-msg: The resource to the URL or file is currently unavailable.;